Back to overview
Downtime
Sites down
May 14 at 11:38am UTC
Affected services
mitchells.work
mitchells.eu
miworks.eu
login.mitchells.work
vlink.mitchells.work
Resolved
May 14 at 11:45am UTC
Issue has been resolved
Affected services
Created
May 14 at 11:38am UTC
There was an issue with the automatic certificate renewal causing all services to be down.
Affected services